Adzilla pages not working, and cannot contact. Anyone else seeing this?

I set up my domain and site a few weeks ago in adzilla based on the lessons. They worked at first, but now it’s been almost a week since any of the landing pages have worked.

Each page brings up:
This site can’t provide a secure connectiondfmarketing.store sent an invalid response.
ERR_SSL_PROTOCOL_ERROR

I have tried twice to go to contact in adzilla, and I get the whole form filled out, but when I subit, it always comes back with:
“An error occured while proccesing the form. Please try again
(Invalid Nonce. Please refresh your browser)”

Any help would be appriciated

Hey there. If you haven’t already, email [email protected] and they should get back to you within a few hours or a day by the latest.

If you’re seeing this error, I can tell you what’s likely happening.
After a lot of narrowing down, it turned out to be my internet service provider’s problem. Their modem they provided me has some kind of ‘police’ firmware. And it blocked my domain. There’s a place where you can see what it does, and it comes up as “questionable”, then blocked. Not for any particular reason, that I did, just did. I say call your internet provider and bring this up if you see this issue.